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excerpt from chapter fi fteen
3D

multi-pass rendering

After Effects is used for many different 

purposes but the area in which it is 

probably most widely used is in the post-

production of footage. For those of you 

unfamiliar with the term, this is when the 

produced footage, image and animation 

are put together and any effects; color 

treatments or graphics are added.

Quite often the compositor will have to 

mix 2D and 3D footage together at this 

stage, their job is to make sure that the 

‘joins’ between these two worlds are 

seamless. 

You’ll often fi nd, when talking to artists 

and designers that they tend to have a 

preference towards working in either a 

2D or 3D environment. I’ve often over-

heard individuals complaining that they 

feel ‘uncomfortable’ outside their chosen 

environment.

Being from a fairly traditional 2D back-

ground myself, I have only begun getting 

into 3D animation quite recently, in fact 

my interest only really started grow-

ing when working with some of the 3D 

concepts introduced in After Effects 5. 

One of the things that in the past put me off some 3D animation 

was the fact that it was too unrealistically ‘real’, too perfect, 

shiny and polished. I prefer work that has more of an edge to 

it, you know, with a slightly grungy quality. 

In recent years I’ve seen some really impressive 3D work, which 

displays these qualities. After researching the techniques used 

to produce these works I discovered that the all too important 

fi nishing touches were often added in post-production with 

applications such as After Effects. All the things that make a scene 

more realistic can be added after the 3D render is complete. 

To make these 3D renders easier to edit and to make them 

more fl exible you can render the image or movie out as a 

multi-pass render. 

Here is a frame from a fi nished QuickTime movie that I will teach you  

how to create using a Cinema 4D multi-pass render, Zaxwerks Invigora-

tor and a smattering of effects!
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I have recently become interested in learn-

ing more about 3D, in fact I’m currently 

trying to fi nd time to spend with my two 

3D applications of choice: Alias Wavefront 

Maya and Maxon Cinema 4D XL (C4D). 

It may seem quite odd to you that I have 

two favorites but, up until fairly recently, 

Maya’s price was out of the reach of most 

small production houses, it also has 

a complicated installation procedure. 

This makes it diffi cult to transport the 

software from one machine to the next, 

this is something that has to be done at 

times when freelancing. Whenever I work 

away from my studio I take my copy of 

C4D to install on the machine where I 

work (I also remove it from the same 

machine when I fi nish the job!!)  Cinema 4D 

is an excellent, low cost alternative which 

can pretty much match Maya feature for 

feature, its interface is  very similar to 

that of Maya. Plus it has some unique 

features, which we will take a look at in the 

following tutorials.

Tim Clapham, a very talented designer at 

HYPA solutions in Brighton, England and 

myself, designed these tutorials. Tim con-

centrated more on the Cinema 4D aspects 

whilst I concentrated on the After Effects 

side of things. In a way, this echoes the 

way that many real world studios work: 

one designer passing the 3D materials 

onto the post artist for effects and fi nish-

ing touches.

There are two main sections to this tuto-

rial. This is the fi rst part of the tutorial; 

it shows you how to set up a scene in 

Cinema 4D. The second main section 

shows you how to adjust elements of 

this 3D scene in After Effects.

What is a Multi-pass Render?

These passes are then composited together in a compositing programme 

such as After Effects where they can be adjusted using transformations, 

blending modes and effects. 

We’re going to take a look at a couple of techniques for re-composing 

these Cinema 4D multi-pass renders within After Effects.

A multi-pass renders each element of the scene as a separate pass, for 

example: below are some of the individual passes that can be rendered 

from Cinema 4D: depth, refl ection, and diffuse values respectively. 
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If you want to skip straight to the After 

Effects sections, please open the PDF fi le 

named AE_Multipass.pdf.

For the fi rst part of this tutorial we shall 

be creating a tile texture to place onto 

the fl oor. This will involve only proce-

dural channel shaders. This means that 

the texture will be created using math-

ematical calculations rather than bitmap 

images. The advantage to this is that no 

matter how close you get to the material 

it will never pixelate. Also it means the 

texture is saved directly within the scene 

fi le without any need for external image 

fi les. We will create the texture using all 

built in channel shaders that ship with 

C4D 7+. These include the excellent 

bhodiNUT smells like almonds shaders.

1 Open ClubFront_Start.C4D from the 

multipass folder.

2 Firstly go to the Material Manger and 

create a new material by selecting 

 File > New Material. (see Fig.1)

3 Double-click the new material swatch 

to open up the Material Editor. 

Rename it ‘Floor’ by typing in the fi eld 

at the top left of the Material Editor. 

(see Fig.2)

4 In the Texture section of the color 

channel (next to the blank text box) 

click on the little wing menu and select 

bhodiNUT Channel > bhodiNUT fusion. 

Then click on the edit button below to 

bring up the bhodiNUT Fusion dialog 

box. (see Fig.3)

1  creating     creating     
the fl oor  

     texture

Figure 1: Cinema 4D’s Material Manager

creating     

Figure 2: Cinema 4D’s Material Editor

Figure 3: bhodiNUT’s Fusion ‘Smells Like Almonds’ dialog box.
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By using Fusion we are able to combine several textures 

together using masks and various composite modes. You can 

even use Fusion within Fusion to create texture trees. We’ll use 

it to create our tile pattern and then roughen up the texture 

with some noise.

5 In the Fusion dialog box go to the base channel section at 

the bottom right and click on the little arrow and select 

bhodiNUT channel > bhodiNUT tiles. Click the edit button to 

bring up the dialogue box for bhodiNUT Tiles. (See Fig.4)

6 The tile shader is for creating various regular patterns 

including tiles. 

7 Click on grout color and pick a neutral gray. We will make the 

tile colors slightly different to add variety to the texture. 

8 Click on tile color 1 and select a light beige color. Click on 

tile color 2 and select a similar but different color to the 

color you selected for the fi rst tile. 

9 In the pop up list select squares as the shape of our tiles, 

have a look at the other patterns available while you are 

here, then go back to squares. 

10 Set the grout width to 0.1% and the bevel width to 0.5%. 

11 Lastly we need to scale up the tile shader so the tiles are 

not too small for our scene. In the global scale fi eld enter 

500%. 

12 Click OK to return to the Fusion dialog box.

We will now create a noise texture to blend with the tile pattern. 

This will create a more interesting texture but more impor-

tantly it will help to break up the uniformity of the tiles. 

13 In the Blend Channel at the top, click on the wing menu and 

select bhodiNUT 3D Noise. Click Edit to open the 3D noise 

shader which can been seen pictured in Fig. 5.

3D noise is one of the most valuable shaders in the bhodinut 

collection. It generates 3D noise that is totally seamless so 

therefore will tile infi nitely. There are various types of noise 

you can generate and they can also be animated. 

14 Set the global scale to 400%. Set the noise type as FBM and 

increase the contrast to 81%. Click OK to return to the Fusion 

dialog box.

Figure 4: The bhodiNUT Tiles 

Figure 5: The bhodiNUT 3D noise 
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On the left hand side of the Fusion dialog 

box is the section that determines how the 

two channels are blended together using 

composite modes (add, difference, mul-

tiply etc). These should be familiar with 

most users who have used the blending 

modes in Photoshop or After Effects. 

15 Select multiply as the composite mode. 

This will multiply the noise shader with 

the tiles shader. The result is far too 

harsh, if we lower the blend down to 

5% it is much more subtle. This will be 

enough to randomize the look of the 

tiles just slightly. 

16 Click OK to close the Fusion box.

17 In the bottom right corner of the 

material editor click the ‘refresh’ 

button. The material icon in the 

material manager updates with your 

new settings. Next we will add a bump 

map to the tiles to give them an illusion 

of a relief. 

18 In the list of properties (left side of the 

Material Editor) click the checkbox 

next to the Bump property to switch 

the Bump channel on. (see Fig.6)

We need to match the bump with the color 

channel so that the places where there is 

grout in the color channel match the same 

areas in the bump channel. The easiest 

way to do this is to copy them from the 

color channel. 

19 In the Properties list, click on the 

word ‘Color’ to jump back to the Color 

channel. In the Texture section, click 

on the little wing menu and select Copy 

Channel. This copies our Fusion settings 

including any shaders within Fusion. 

20 In the Properties list, click on the word ‘Bump’ again to go 

back to the bump channel (see Fig.6), 

21 Click on the wing menu and select bhodiNUT Channel > 

bhodiNUT Fusion. Click Edit to open the Fusion settings. 

22 In the Base channel click on the wing menu and select 

Paste Channel. This will paste in the Fusion settings you 

just copied from the color channel (See Fig.7). 

Figure 6: The Bump property in the Materials Editor

Figure 7: The Material Editor

Figure 6: The Bump property in the Materials Editor
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The reason we are adding this to another 

Fusion shader is to create another layer of 

texture to the bump, on top of the copied 

settings. This is an example of a simple 

texture tree.

23 In the blend channel at the top, click 

on the little arrow and select bhodinut 

channel > bhodinut 3d noise. Click Edit 

to open the settings. 

Here I want to create a fi ne grain texture 

that will add to the realism of the bump 

and also it will help to diffuse any 

refl ections (which we’ll add later). 

24 Leave all the settings at their default except for global scale. 

Change this to 10%. Click OK to return to the Fusion dialog 

box.

25 In the Mode pop up list (on the left) set the composite mode 

to Multiply and lower the blend to 16%. Click OK to accept 

these settings. We now have a rougher texture overall.

26 To make the material refl ective click the checkbox next to 

the Refl ection channel to make it active (See Fig.8). 

27 In the Texture section, click on the wing menu arrow and 

select Paste Channel. This will paste in the same Fusion 

settings as you’ve used in the Color and Bump channels. 

28 Click Edit to open the Fusion settings. 

Increase the blend to 21% making the 

noise slightly more apparent. 

29 Click OK. By using these settings again 

the tiles will refl ect less in the darker 

areas (such as the grout). 

30 We only want this to affect the refl ection 

slightly so in the Texture section set the 

Mix value to 16%. 

The amount of refl ection is still far too 

high but we will leave it as it is and use the 

multi-pass rendering feature of Cinema4D 

to render the refl ection separately later. 

This will demonstrate how much extra 

post render control has been added with 

the multi-pass render option. 

31 Click on the checkbox for the Specular 

channel. This is where you can control 

the specular highlights of the texture 

(See Fig.9). The tiles need quite a wide 

fl at specular value. 

32 Set the width to 79% and height to 

16%. Set falloff to 10% and inner width 

to 16%. 

Figure 8: The Refl ection ChannelFigure 8: The Refl ection Channel

Figure 9: The Specular ChannelFigure 9: The Specular Channel
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Change these settings to get an under-

standing of how each slider controls a 

different parameter. It is much easier for 

you to experiment here and see the results 

than for me to explain them. But basically 

we have made a highlight that is quite wide 

yet not too bright. The falloff is gradual 

and the inner width gives you a fl at area in 

the middle of the specular. The tile texture 

is nearly fi nished now.

30 Click on the Diffusion checkbox to 

activate this channel (See Fig.10). The 

diffusion channel does exactly what 

is says, it diffuses the texture. In the 

top right of the diffusion channel are 

3 check boxes to say what is being 

diffused. Specular should be checked. 

31 In the texture section click on the little 

wing menu and select bhodinut channel 

> bhodinut 3d noise. Click Edit to open 

up the settings for 3d noise. 

32 Set the Global Scale to 500%. Select FBM 

as the Noise type from the Noise popup 

menu. 

33 Set Contrast to 76%. Lastly make color 

1 a dark gray and color 2 a light gray. 

This should be suffi cient to diffuse our 

tiles subtly, click OK to close the 3D noise 

dialog box. 

34 In the texture pane of the diffusion 

channel set the mix to 30%. The tile tex-

ture is now complete so you can close the 

material window.

35 In the Material Manager (the strip 

along the bottom of the main window) you 

can see the new fl oor texture. Click on the 

Floor material swatch and drag it over to 

the Object Manager (see Fig.11).

36 There is an object called fl oor. Drop 

the material onto the little icon next to 

the word fl oor. This icon looks like a blue 

triangle with brown dots at its corners; this shows that the 

object is a polygon object. 

Figure 10: The Diffusion Channel

Figure 11: The Object Manager

object is a polygon object. 
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When you drop your texture on to it a 

dialog box will open (See Fig.12). Here you 

determine how you would like to place 

this material onto this object. 

37 In the Projection menu select Cubic. 

This will project the material onto the 

object as if onto the faces of a cube. 

This projection type works well as 

our fl oor object is a cubic shape (well, 

rectangular).

38 Make sure that the checkbox next to 

tile has a check in it. Set the length to 

65% for both X and Y. Click OK. 

On the left hand side of the Object Manag-

er you will now see a small icon represent-

ing your tile material. This is your Texture 

tag. We have now tiled the fl oor! 

39 Go to the Render menu>Render View 

(Control/Right mouse + R) to do a quick 

render of your scene, this will render 

the results of your work in the editor 

window. 

NB If you see a Texture Error window 

informing you of missing fi les, just 

ignore it for now and click OK.

The tiles are going into the doorway, so to restrict the tiles 

to the fl oor outside we will use a selection set. I have already 

created this for you. In the Object Manager you will notice a 

small red triangle to the right of the fl oor object, this is  a tag. 

(See Fig.13)

Figure 12: The Texture dialog box

40 Double click it and you will see it is named Outside. This 

is a selection of polygons that are outside the building. By 

specifying this in the texture dialogue box we can place a 

texture only on these selected polygons. 

41 To see the selection set select Restore Selection. In the Main 

window you will now see the area selected.

42 To restrict the tiles to this polygon double-click the tiles 

Texture tag. (See Fig.13) This brings up the texture window 

again. 

43 In the Restrict to Selection text box type in the word,  

‘outside’. (See Fig.14)

44 Click OK and then do a test render again to see that the 

texture is now restricted to your selection. (Control/Right 

mouse + R)

45 In the main menu go to File>Save As. Save your Cinema 4D 

project to a new folder named Finished C4D projects.

Figure 13: The Floor object’s Tags

Polygon 

Selection tag Texture tagTexture tag

Figure 14: Type the word ‘outside’ into the Restrict to Selection text box 

outside
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8 Click the edit button to bring up the 

Fusion shader settings (See Fig.16). 

6 Next click on the tick next to the Diffusion channel to activate 

it. Here we will add some noise to the texture to break up 

the uniformity and make the wall look more weathered. 

7 Click on the wing menu and select bhodiNUT Channel > 

bhodiNUT Fusion. 

Figure 15: The Material Editor

9 In here we are going to combine two 

types of noise. In the Base channel at 

the bottom of the box, click on the wing 

menu and select bhodiNUT Channel > 

bhodiNUT 3D Noise. 

10 Click Edit to open the 3D Noise settings 

(See Fig. 17). 

11 Set global scale to 1500% so that the 

noise diffusion will be spread widely 

over the wall rather than lots of smaller 

blotches. 

12 In the Noise section, select FBM as the 

noise type. 

2 creating the 
wall texture

The second texture we will make will be for the walls. This 

will make them look more realistic, let’s start by adding 

our basic texture.Then, later in the tutorial you’ll add your 

own graffi ti and dirt to add to the realism. 

1 From the Multipass>Cinema 4D projects folder, open the 

fi le named clubFront_01.c4d. this is a pre-saved version of 

the fi le that you just saved.

2 Start by going to the Material Manager and selecting File > 

New Material. 

3 Double click this material to open the Material Editor. 

4 Rename the material walls in the top left fi eld. The color 

channel will be active. 

5 Pick a color. A typical light beige outside wall color (R-100%, 

G-98%, B-94%) and brightness 85% (See Fig. 15).

Figure 16: The Base channel

Figure 17: The 3D Noise settings
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13 Set brightness to 50% and contrast to -50%. Click on the 

Color 1 swatch and choose a dark brown color (e.g. R-11%, 

G-7%, B-0%). 

14 Click OK and then click the Color 2 swatch. Select a pale 

beige color similar to the materials base color. 

15 Click OK to confi rm this color and then click OK to accept 

your settings for the 3D noise shader. 

16 Now back in the Fusion shader dialog box select the wing 

menu for the Blend channel (at the top of the box.)

17 Choose bhodiNUT channel > bhodiNUT 3D Noise and then 

click the Edit button to open the settings for 3D Noise (See 

Fig. 18). 

18 This time we will use the default Noise, so make sure it 

is selected in the Noise popup list. This type of noise is 

much softer than FBM noise so combining the 2 noise types 

should create a good diffuse texture which will look quite 

random. 

19 Choose a global scale of 500% and set the contrast to -50%. 

Select 2 colors for the noise as you did in the last step but 

make them very slightly different, a dark brown and a light 

brown. Click OK to close the 3D noise dialog box and return 

to the Fusion settings.

20 I chose to use Screen as my composite mode and I set the 

blend to 75%. By all means try different settings here to 

blend the 2 noise types. Once you are happy click OK to 

close the Fusion shader settings.

21 In the material editor I chose to set the Diffuse Mix value to 

50% so that it wasn’t too obvious; choose 

your own setting here.

22 Next click on the tick next to the bump 

channel to activate it (See Fig.19). The 

wall should have an overall even bump 

that will define the plaster and then 

there would be areas with small chips 

and imperfections. So again we are going 

to use Fusion to combine several noise 

types. 

23 Select bhodiNUT Channel > bhodiNUT 

Fusion from the wing menu and then hit 

the Edit button to open the settings. For 

the Base channel we shall create a fi ne 

noise that can simulate a sandy kind of 

texture. 

24 Select bhodiNUT Channel > bhodiNUT 

3D Noise and click Edit to open the 

settings (See Fig.20). 

25 Change the Global Scale to 4% and then 

click OK to close the box and accept the 

changes.

Figure 18: The 3D Noise settings

Figure 19: The Bump channel



10 chapter fi fteen: 3D

Creative After Effects 5.5  © 2002 Angie Taylor. All Rights Reserved    http://www.angie.abel.co.uk/book.html

 chapter fi fteen: 3D 11

Creative After Effects 5.5  © 2002 Angie Taylor. All Rights Reserved    http://www.angie.abel.co.uk/book.html

26 Back in the Fusion settings, for the 

Blend channel select bhodiNUT 

Channel>bhodiNUT 3D Noise and then 

click Edit to open the 3D Noise settings 

(See Fig. 21). This time we will make 

some random marks so that the surface 

of the wall appears to have some chips 

or imperfections. 

27 Choose FBM noise and set the global 

scale to 300%. Choose a dark gray for 

color 1. 

28 Now set the brightness to 40% and the 

contrast to 85%. In the preview you may 

only see a white cube but there is some 

noise there, believe me! 

29 Under the preview there is a popup 

list where you can select the type of 

object that you wish to preview your 

texture on. Select Plane from the list. 

You should be able to see some small 

gray marks in the preview pane now.

30   Click OK to 

return to the 

Fusion settings. 

We need to 

combine these 

2 noise textures, 

I chose to use 

multiply with a 

blend setting of 

85%. This should 

give us the illu-

sion of an overall 

sandy/granular 

texture with the 

odd chip taken 

out. Click OK 

to return to the 

Material Editor.

31 Select the Specular channel and set width to 80% and height 

to 15%. We now have a wide and fl at specular (see Fig.21b).

32 Finally, close the Material Editor. You can now see your new 

Walls texture swatch in the Texture manager.

 33 Go to File>Save As. Save the fi le to your Multipass>Cinema 

4D projects folder as clubFront_02.c4d.

Figure 20: The 3D Noise settings Figure 21: The 3D Noise settings

Figure 21b: The Specular settings
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3cleaning 
        windows

Before we add graffi ti and dirt to the walls to add to the realism, 

let’s put some glass in our windows to remove the wall texture.

1 Open clubFront_02.c4d from Multipass>Cinema 4D projects 

folder. In this scene there are two objects that need the Walls 

texture, they are named Big wall and Front wall. 

2 Drag the walls texture from the material manager and drop it on 

the icon for Big wall in the Objects editor. The Texture box will 

appear, when it does, click ok to accept the default settings.

3 Repeat this process, this time dragging the wall’s texture to 

the Front wall object. Click OK in the Texture box to accept the 

settings. 

On the front wall object there are three recesses above the 

door. These are intended to be windows. We need a glass 

material to place on there. Firstly however we will restrict the 

wall texture so it does not map to these polygons. We will do 

this using selection sets as we did for the tiles texture. This 

time we will create the selection sets.

4 Choose the Polygon tool  

and make sure the Front 

wall is the active object by 

clicking on it in the Object manager. 

5 Hit F4 to toggle to Front view so that 

you can see the doorway and the  three 

Polygons above it more clearly. 

6 All three polygons should already be 

selected but if not, click on the fi rst 

window polygon to select it. By holding 

down shift you can then add the other 

two polygons to your selection. When 

a polygon is selected it will change 

from blue to red. You will also know 

that it is selected because you will see 

a yellow dot appear in its centre, this 

is a symbol for the polygon normal 

(centre point). 

7 Hit F1 to switch back to View 1 to 

confi rm you have selected the correct 

three polygons (See Fig.22).

8 Go to the selection menu at the top 

of the screen and select Selection > 

Set Selection. 

Figure 22: Your scene as seen in View 1
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9 In the Object Manager the ‘front wall’ 

object now has a small red triangle to 

the right of it; double-click this icon and 

the Polygon Selection dialog opens. 

10 In the Name fi eld type ‘windows’ (Fig.23). 

15 To do this double-click the Front Walls texture tag. 

16 In the Texture dialog  box that opens type the word 

‘Walls’ in the Restrict to Selection fi eld. Click OK to 

accept the change, this will ensure that the texture is only 

applied to the Walls selection, not to the windows.

The windows need a texture that is semi-transparent and gives 

the illusion of light emitting through it. This will be quite a 

simple texture to create. 

17 In the Material Manager go to File>New Material to create 

a new material swatch. 

18 Double-click the new material swatch and name it ‘Glass’. 

19 Uncheck all of the attributes on the left side except for Color 

and then click on the word Color to make it active.

20 To simulate the warmth of the interior lights we shall use 

a yellow for the glass. 

21 For the Material Color choose a color that is a light yellow 

(e.g. R-100%, G-95%, B-40%; Brightness - 100%) (See Fig.24). 

11 Click OK to close this dialog box. You 

have saved a selection set for the 

windows. 

12 Go to the Selection menu and choose 

Selection>Invert. This will select all the 

polygons except the windows set. 

We can also save this selection set as 

walls, but before you do that you must 

deselect the current selection set tag 

otherwise you will replace it with this one. 

13 On the Object Manager click away from 

the selected tag to deselect it (NB: It 

should not have a red selection square 

around it when it is deselected).

14 Now go Selection>Set Selection. A 

new selection tag is created without 

replacing the original, double-click the 

new tag and name it ‘walls’.

Now we have created the selection sets 

we can restrict the wall texture to the wall 

without it affecting the windows. 

Figure 23: Polygon Selection window

Figure 24: Activate the Color channel

The next shader we shall apply is part of the bhodiNUT ‘Smells 

Like Almonds’ collection. We shall use the luminance channel 

to give the illusion that light is emitting from the windows. 

22 Click the checkbox next to the luminance channel  to 

activate it. 
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23 In the Texture section wing menu 

select bhodiNUT Channel>bhodiNUT 

Banj and then click Edit to open the 

settings for Banj (See Fig.25). 

Banj allows you to gather illumination from 

the back of a surface. This will allow light 

out of the windows yet will not allow us 

to see inside. 

24 Click on the Color swatch and choose 

a yellowy-orange color (e.g. R-100%, 

G-85%, B-20%). 

25 Set the Illumination value to the 

maximum value of 80%.We don’t want 

shadows so leave the rest of the settings 

as they are and click OK.

Figure 25: Banj settings

Figure 26: Adding Transparency

Figure 27: Restricting the selection to the windows polygons

26 Click on the checkbox next to the 

transparency channel to activate it (See 

Fig. 26). We will have slight transparency 

on the front face so that you can just see 

some tone on the back wall through the 

window. Again choose a yellow for the 

color. I chose R-100%, G-80%, B-0%. The 

material is far too transparent so set the 

brightness to 20%.

27 We have finished with the Material Editor so close its 

window. 

28 Locate the Glass material in the Material Manager and drag 

it onto the Front wall object icon in the Object Manager. 

29 When the texture dialog box appears, type ‘windows’ in the 

Restrict to Selection fi eld (See Fig. 27). 

30 You can leave all the other settings at their default. Click 

OK.  The window texture is now applied to the front wall 

object but restricted to the selection set we created for the 

window polygons.

31 Go to File>Save As. save the fi le to your Multipass>Cinema 

4D projects folder as clubFront_03.c4d.

In my fi nished 

project I have 

taken an extra 

step of adding 

the two panels 

adjacent to the 

doorway to 

my windows 

selection. See 

if you can work 

out how to do 

this after saving 

the fi le.
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4   playing dirty         
         with    

            graffi ti

5 Locate the Multipass >Cinema 4D 

projects>Tex folder and then select  

‘graffi tti.psd’. (See Fig.28)

This image will then load and you’ll see 

it in the preview. Before we do anything 

else we need to isolate the graffi ti from 

its background otherwise we will end up 

with a big white square covering our wall 

texture, to do this we need to use an alpha 

channel. 

alpha channels
An alpha channel is a fourth channel 

which can be saved within an image (the 

other three channels being Red; Green 

and Blue color channels). It is a grayscale 

channel which represents the transpar-

ency values of an image. 

Basically where ever the alpha channel is 

black it will make the material completely 

transparent and where it is white it will 

be completely opaque. All the grays in-be-

tween will be at various levels of transpar-

ency depending on their value. 

Understanding channels is essential 

when working in graphics or animation. 

If you haven’t done so already, check out 

the 01_Technical.pdf document on the 

Creative After Effects 5.0 CD ROM (Extras 

folder) to learn more about channels.

6 Click on the checkbox to activate the 

Alpha channel (See Fig.29). 

7 Click the wing menu in the texture pane 

and select Bitmaps>Graffi ti.psd.

8  Make sure that the box that says Image 

Alpha is checked. Notice that doing this 

has made the background of the graffi ti 

transparent in the preview window.

Finally, let’s add some extra realism to the Big Wall object by 

adding some graffi ti. This is  an exercise in using alpha chan-

nels within textures. The technique we will use would be 

the same if you were sticking a label on a bottle, it will also 

show you how to use bitmap images within your textures.

Included with the project files are also several bitmap 

images. These are stored in the Multipass>Cinema 4D projects>

‘Tex’ folder. 

1 Open clubFront_03.c4d from Multipass>Cinema 4D projects 

folder.

2 In the Material Manager go to File>New Material to create 

a new material. 

3 Double-click the material and name it graffi ti. Make sure 

that the only active channel is Color by unchecking any 

other properties in the list.

4 Click on the Color channel to make sure it’s active and 

then click on the Image button to load an image into this 

channel. You will be presented with a standard system 

open fi le dialog box. 

Figure 28:  Building a Graffi ti texture
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In this case the alpha channel is embedded in the image, which 

is why we selected Image Alpha. Alternatively you could use a 

separate grayscale image to create areas of transparency.

Not all image formats support embedded alpha channels but 

Photoshop fi les do. An image with an alpha channel is defi ned 

as RGBA, where the RGB stands for red, green and blue and the 

A stands for alpha. There is also more information on alpha 

channels and how they can be used in Cinema 4D in the C4D 

manual (pages 410 & 511).

9 Close the Material Editor.   

10 Drag the graffi ti texture from the material manager onto the 

icon for the ‘Big Wall’ object. The texture dialog will open 

(See Fig.29). 

11 From the Projection Type popup list 

select Flat. This will ensure our graffi ti 

is fl at on the wall. 

12 At the bottom of the Texture box are 

3 sets of fi elds for Position, Size and 

Rotation. For position set Y to -226 and 

Z to -397. 

13 In the Size fields at the 

bottom set X to 614m and set 

Y to 259.5 m. This is a 2D texture so the 

Z dimension is not relevant.

14 Lastly in the Texture box set the H rotation 

fi eld to 90º. This will ensure our graffi ti 

texture is at the correct angle for the 

wall. 

15 Click OK to confi rm these settings. 

16 Go to Render>Render view to see the 

grffi ti applied to the side wall in the 

scene.

17 Go to File>Save As. save the fi le to your 

Multipass>Cinema 4D projects folder as 

clubFront_04.c4d.

Figure 28:  Building a Graffi ti texture

Figure 29:  The settings for the Graffi ti texture
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5      Animating 
 the camera

Figure 30: Parental heirarchy  for the camera

As this tutorial is aiming to cover the newer features of 

Cinema 4D I have  already animated the camera. However I 

would like to explain the technique that I have used so you 

can use the same technique in your work. 

Cinema4D has some very sophisticated and complex anima-

tion tools, and for some people they are not surprisingly quite 

mystifying! I learned the following method from an internet 

forum, a regular poster there, ‘JeremyW’ has a website which 

I would strongly recommend visiting. The technique I have 

used is described there in more detail so make sure you take a 

look: http://www.jeremyw.com/C4D_Stuff/C4D_Links.html

Basically you create several Null objects, one for each main 

camera move. You then make each Null a child of the next Null, 

with the camera being the fi nal child (See Fig.30). 

Then instead of animating the camera you animate each null in 

turn. By using this technique you create a separate Position, 

Rotation etc. sequence for each camera move. 

You may be thinking “why is this advantageous to me?” Well 

if you’ve ever struggled with Cinema 4D’s 3D space or time 

curves then this will make your life  much easier. By creating 

a separate sequence for each camera move it is much easier 

to ease in and out and create a smooth motion. 

1 Open clubFront_04.c4d from 

Multipass>Cinema 4D projects folder.

2 In the scene open the Timeline by 

selecting Window> Timeline.

3 Scroll down until you see the hierarchy 

that starts with parent 01. 

4 If it’s not already visible you can expand 

this group by clicking on the small cross 

to the right of the text to see all the child 

null objects and the camera as the fi nal 

child. 

5 Each null object has a rotation and 

position sequence. Notice that they all 

overlap slightly. 

6 To see the Time Curves as they appear 

in the diagram, go to the Timeline menu 

and select Window > Time Curves. 

(See Fig.31)

7 If you click on parent 01 you will see a 

group of graphs appear in the right of the 

window. Hit the Green preview 

button to preview the camera 

move. Drag the Time Marker 

back to frame ‘0’ when you’ve fi nished 

previewing.

Figure 31: Parental heirarchy  in the Timeline, notice the camera animation paths
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8 Click on the Position or 

Rotation track of each null 

object individually (parent01, 

parent02, etc.) to see that each 

sequence has its own curve 

(See Fig.32).

9 These curves are simple ‘S’ 

shapes. Essentially the curve 

represents the speed of the 

movement, the steeper the 

curve the faster the motion 

whether it be Position, 

Rotation, or any parameter. 

By understanding this principle you can 

see that the movement starts slowly as 

the curve is quite horizontal, and then ac-

celerates to a linear motion (the diagonal 

section of the curve) and then fi nally it 

gradually slows again as the curve be-

comes horizontal again. 

By treating each sequence like this you 

can control how much you ease in and 

out of each move. Then by taking each 

sequence and overlapping them slightly 

you can ease in and out of the different 

moves you have created, this creates a 

smooth overall camera animation without 

any harsh transitions. It also gives you 

precise control over each individual move 

so you can fi nely tune your animation 

velocity. This technique makes cinema4D 

time curves much more friendly.

Using the Camera settings, we can cre-

ate a depth map that we can use in After 

Effects to adjust the amount of depth of 

fi eld (DOF) in the scene. Cinema4D applies 

DOF as a post-render effect; this works in 

a similar way as applying a fi lter to an im-

age in Photoshop after you have taken the 

photograph. 

Consequentally you are left with little control over this, once 

you have rendered your images this DOF is applied. To make 

this render more fl exible it would make more sense to render 

a sharp image and then add the DOF in post-production which 

is what we will do in the following tutorials. This way you have 

a sharp render and you can control the level and depth of blur 

in a much more versatile way. Also, maybe more importantly 

you can render various levels of DOF much more quickly to 

try out different looks. 

Another thing that makes adding DOF in post an advantage is 

that you can simulate rack focus more easily, that is changing 

the point of focus from one object to another through DOF. 

1 To set the DOF double click the camera icon in the Object 

Manger. This will open a new window containing the Camera 

settings (See Fig.33). 

Figure 32: Individual Rotation track curve for Parent01

Figure 33: Camera settings box
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2 On the right side of the window you will 

see the Depth of Field section which 

contains a pop-up menu, click there 

and select Rear from the list of choices. 

This will mean we are defining an area 

to the rear of the point of focus that we 

want to blur. 

The three fields underneath are quite 

self-explanatory: The first (Front Focus) is 

grayed out, as we have selected rear focus 

only. It refers to the point at which objects 

in the foreground will be completely 

blurred.  The second value, (Sharpness) 

defines at which point the camera is in 

focus. The last (Rear focus) defines the 

point at which the objects beyond the point 

of focus are completely blurred. 

We will use these camera settings to 

create a depth map and will apply the 

DOF in post rather than using the Cinema 

4D DOF effect. 

3 Change the ‘Sharpness’ to 1300m and the 

rear focus to 2800m. This creates a fairly 

even transition of depth for this scene.

4 Go to File>Save As. save the file to your 

Multipass>Cinema 4D projects folder as 

clubFront_05.c4d.

These parameters will vary from scene to 

scene so the best way to understand them 

is to experiment. The way I remember it 

is that the furthest object must be just 

reaching white, the point of focus should be 

black and the nearest point to the camera 

should be just reaching white again (front 

& rear focus). The post blur effects that 

you can apply will take this brightness 

level and blur the image according to its 

level of brightness, i.e. dark - in focus and 

light - blurred.

6 rendering   
 multiple 

              passes
Now the scene is complete we are going to output the 

animation ready for importing into Adobe After Effects 5.5. 

Cinema4D will create a file that you can import into After Ef-

fects. This will contain a ready-made composition containing 

all the multi-pass layers layered correctly with the correspond-

ing composite modes already applied.

As I mentioned at the start of these tutorials the multi-pass 

feature in Cinema4D enables you to export separate layers for 

post editing of shadows, reflections, DOF etc. The multi-pass 

feature enables you to finely tune the look of your image or 

movie without re-rendering the 3D, just by adjusting each layer 

in post production. Multi-pass can also output a depth map that 

you can use in post for adding depth of field. 

Cinema4D will also export camera and light data from the scene 

and these will imported into After Effects’ own cameras and lights. 

By using multi-pass to export information on these elements you 

can change the effect of your original lighting setup or match 

camera moves with new, composited elements in the scene.

We will also be outputting an  RPF sequence. RPF files can con-

tain extra information about your 3D scene. They are capable 

of including Z-depth information; Object ID; UV coordinates; 

plus other information. After Effects has a keyframe assistant 

designed to import camera animation data from RPF files. I’ll 

show you how you can use this to import the Cinema4D camera 

path and apply it to our After Effects camera. 

Another useful feature of multi-pass is the ability to render 

object buffers; using render tags on the objects and specify-

ing a number for each object achieve this. In the multi-pass 

render settings you can then output a unique alpha image for 

each object specified. This means it is easy to isolate particular 

objects in post-production, if for instance you wanted to add a 

glow around a specific object but needed the control and speed 

you would get in After Effects. 
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1 Open clubFront_05.c4d from 

Multipass>Cinema 4D projects folder.

2 Open the Scene Render settings by 

selecting Render>Render Settings. The 

fi rst section you will see is the General 

section, a summary of your settings 

Leave this as it is (See Fig.34).

3 Click on Output in the list on the left. 

This is where you decide the resolution 

and frame rate of your output (See 

Fig.35). This scene is set up as a 16:9 

composition. 

As I work in the UK I will use settings that 

will translate easily to PAL. Normally for 

a widescreen PAL render I would output 

my scene at 1024 x 567 square pixels. For 

this project I chose to use half these di-

mensions, 512 x 288 pixels (to speed up 

downloads the movies that are available 

from the website are 320x180, 8 fps).

4 In the Pixel section, change the settings 

to 1:1, this will produce a square pixel 

aspect ratio. 

5 Click on the Frames popup menu and 

select All Frames. 

6 Leave Field Rend at None as we won’t 

need to render fi elds. 

7 I chose 25 frames per second as my 

frame rate as that is the standard for 

PAL, however you can choose the frame 

rate that suits you (e.g. NTSC 30fps). 

8 Click onto the Save section  (See Fig.36). 

Make sure there is a check in the box 

next to Save Image. 

9 Now click on Path. You will be presented 

with a standard system save dialogbox. 

Navigate to the location on your hard 

drive where you wish to save the render. 

Create a folder named ‘My Multipass ‘to 

save the all the rendered fi les into.

Figure 34: General Render Settings

Figure 35: Output Render Settings

Figure 36: Save Render Settings
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10 Within this folder create another new folder, name it ‘RPF’.

11 Click Save to return to the Render Settings Save section. 

12 From the Format popup menu select RPF. We are outputting 

the RPF fi le format so we can use the After Effects Keyframe 

Assistant to import the camera information from C4D. 

13 Click on the Options button to see all the options that can 

be included with the RPF fi le. Click OK after looking. 

14 At the bottom of the Save settings is a check box to save an 

After Effects project fi le, check this box. This will save the fi le 

that can be imported directly into After Effects (as long as you 

have the correct plug-in installed  – more about this later). 

15 Click on the Save button and choose to save this fi le into 

your new My Multipass folder (NB: not the RPF folder!)

16 Go to the Antialiasing section and select Best from the popup 

menu (See Fig.37). 

17 Now click Multi-pass to move to that section (See Fig.38).

Figure 37: Antialiasing Render Settings

Figure 38: Multi-pass Render Settings

18 Enable Multi-pass rendering by 

checking the little box next to the 

words, ‘Enable Multi-pass Rendering’.

19 In the top right of the Multi-pass section 

(where it says Channels) there is a wing 

menu to the right of the word Channels. 

If you click here you can select the 

multi-pass layers you want to output 

from the popup menu.

20 First of all, select Diffuse; this ouputs a 

layer that contains the diffuse color. 

21 Go back to the menu and, this time  

select Shadow, this will create a layer 

just with shadows. This is useful if 

you may need to soften the shadows 

or change the shadow color in post. 

22 Next, choose Refl ection. This layer will 

contain all the refl ective information 

so we will be able to make the fi nal 

refl ection more subtle. 

23 Finally, add Depth; Ambient; Refraction; 

Atmosphere; Material color and 

Illumination to the list of  items. 

24 At the bottom of the Multi-pass section click 

on the Path button to choose a destination 

to save your multi-pass render. Navigate to 

the My Multipass folder and create another 

new folder within it named ‘Movies’. Click 

Save to save all the multi-pass movies into 

a separate Movies folder.

25 Choose a fi le format, I chose QuickTime 

movie, but you may wish to choose 

another format depending on your 

operating system.

26 Click OK to leave the Render Settings 

box and then go to File>Save As. save 

the fi le to your Multipass>Cinema 4D 

projects folder as clubFront_06.c4d.

27 Now select Render > Render to Picture 

Viewer to render the animated scene 

to disk. In the next tutorial (AE_

Multipass.PDF) we’ll import this fi le 

into After Effects for post-production.

 


